Bluetti AC200 Display not Functioning

My AC200 turns on and the display lights up. The display shows no information. No SOC, now power in or out, all information reads 0. The charge brick has a green light. Basically it looks like the display is just showing static information, as if the display is just a sticker with blank info.

Try holding the power button for 10 full seconds when the unit is “on” . After releasing the button and the AC200 turns off, re-start and see if the display is normal. If not, try car or solar charging to see if that changes anything. Since you have an AC200, I assume you have had it some time and used it several times. What occurred immediately before with your AC200 that may give some clues as to what the issue is. Basically what was different with this start up vs all the others and what was happening preceding this start up?

1 Like

I tried pushing and holding the button already. It was just plugged in and charging. I noticed that the display was not working.

Hi there,

Sorry for the inconvenience.
Is it normal when you charge the unit with solar panels and car charger? If not, please provide your order number, serial number(at the bottom with bar code), address and phone number.

Here is my Serial number. I ordered from Indiegogo and my order is 8002.

Would it be possible to give a little detail surrounding the circumstances of the issue? Please see my post above from a day ago asking a few questions. I would love to try and help but need some basic info to go on but you have not been answering questions regarding the situation. A few pics of the issue would assist as well.

As I stated in my previous email the unit was plugged in and maintaining a charge. It was not being used. I went out to check that the charge was good as I was planning on using it to power a projector. I saw that the state of charge indicated 0%. The display is non-responsive. The power brick has a green light. I have never used the car charger or solar charging.

My last file was to large.

Another pic

My thoughts are these:
1-The battery may well be at 0 percent state of charge and that is why you are getting no functions. (this could occur if not turned fully off and the AC200 was stored in standby mode and drained the battery to 0 % state of charge and then turned itself off) If the unit is left at 0 % state of charge for an extended period, it may not be able to recover. Not sure how long your unit was off and stored before you tried to start since not stated.

2-You state the charger light is green. This is the color it should display after the charge is complete. Is the charger plugged into the AC200 when you are saying the light is green? If so, the charger may not be operating correctly and hence no charging is occurring. I don’t see any screens that would show any incoming voltage.

3-If you have any way to try the DC car charger, I would definitely do that. You would need to change your settings to “CAR” from where they are now. If the DC car charging cord works then it would be safe to assume the AC charging is not operating correctly or the AC charging circuit in the main unit is not functioning. The important thing at this point would be to try to get some charging to occur to get the battery above “0”

4-you have stated several times that the display is not working and is non responsive but then sent pics of different screen that would have required a response from the touch panel in order for the different screens to display. What specifically do you mean by non responsive.

1 Like

It will turn on and stay turned on. The screen just does not change in any way when I push a button. Like to change how to switch from PV to Car. The voltage for output stays at 100 volts and I cannot change it. It was plugged in and charging. I will try the car charge as suggested.

I still do not understand how you say the screen does not change in any way when you push a button but to be able to display the different screens pictured, a button had to be pressed and the screens responded by going to a new screen.

Ok I attempted to plug into the car charger and the solar. Nothing is working. The screens are the only thing that changes. No settings will change. I can only look at different displays, no info and no settings will change.

If you are unable to select car charging mode you are dead in the water. I can’t think of anything else except Bluetti assistance

Thanks Scott,
They have yet to respond.

I have the same AC200 through indiegogo like you. I have stored it for months at a time and ran it down to 0 many times without issue. You issue def. sounds strange because 0 S0C is not supposed to be a true 0 for the battery with some left for reserve

1 Like

It was charging when it failed. It has never been at 0 since I have owned it. I can leave it on for over an hour no change.

@catof250 if the unit stays on but is still showing 0%… I’d try activating or turning ON both the AC and DC outputs… turn off ecomode, and let that bad boy just sit till it truly runs out of juice… it might just need that “full cycle” depletion to sort of reset itself.

Also I noticed you have 100v and 50hz selected over the 120v and 60hz option… is there a reason for this? If your here in America, select the 120v & 60Hz for AC wall charging.

Keep us posted.

The unit self selected the options for voltage and hz. The buttons are not responsive.

@catof250 Hi there. Please provide some info I have sent to you by message. Don’t worry, we will help you out.