B300 problems -DOA

July 9th ordered 1 AC-300 and 2 B-300s. They arrived surprisingly quickly in two weeks and all powered on, and all were tested to charge fully and deplete full and then recharge. Good story so far.

So on July 24th I ordered the special of TWO additional B-300 batteries. Incredibly (again I had anticipated a long wait) they arrived less than a week later, FEDEX.

First of those B300’s will not power on at all, even with long press just is dark. Also looks like that box was damaged (in shipping or they sent me a return???)
Second of the new B300’s plugged in but showed 0 SOC. it powers on meaning a green light is in the ring on the button, and the % lights come on showing 20% (or less I guess). But even isolated to the AC-300 and just that battery, it will not even power the AC-300 to a start up. When I again attach one or two of my first good B300s the AC-300 starts up and will show those batteries properly, but the “ghost” B300 as 0% SOC and (in the app) “offline”.

I have tried mixing around the cables. It is not the cable. Tried long presses and short presses. NO luck. I called Bluetti customer service and after waiting on hold the “nice lady” message came on saying they were really busy and would “try” to get back to me if I left a message…then the announcement ends and the service says “Bluetti mailbox is full”- you cannot even LEAVE a message, so probably little chance they will call me back.

I have sent three emails. Tried sales and service emails.

NO RESPONSE after two working weekdays (their website says they will respond within 48 hours).

Not sure what to do next except contact my credit card company and reverse the charge with the reason “defective material” or perhaps “Fraud” seeing as I have two 80 lb boxes filled with sand.

Anyone with any more technical information would be very helpful.

At least you still have that going for you. I also have a B300. I topped it off when I got it without issue. I couldn’t get a cable to connect to my AC200P for a month. After receiving the cable, I powered my AC200P until depletion. I am having some trouble recharging, which is intermittent. I am slightly above specified amps, I will admit. I called and experienced a busy signal the first time, and the message and full mailbox the second time. Early this week, I got through and received some help but not what I really needed. If I were you, I would be tempted to return the B300s while I have my credit card company in my corner. Customer service is unresponsive, and I don’t trust them.

Hi WSKCONDOR,

you could try to charge the “dead” B300 just with the DC input to a certain percentage, so not trying via the AC300. At least the PV charging cable should be included.

Only the batteries power the AC300 as it has non inside, so there could be a prevention, like undervoltage is not accepted or battery not recognized when empty.

Even for the AC200Max Bluetti states, empty batteries to be charged seperately first
(AC200MAX Battery Expansion: B230 or B300 - YouTube at ~2:00).

Best regards
Bernd

Hi @WSKCONDOR , Yes, we suggest you refer to Bernd’s method first. Charge the B300 battery separately first and then see if you still get the situation you described before.

@BerndOffGrid ,Thank you for your kind advice :slight_smile:

To begin with, I did not have a random spare DC source laying around. Nor does the product in any way advertise that I need that in order for it to function. IN fact there are warnings about using “unapproved” sources. In any case, the first B300 remains completely dead dead. No lights at all. And needs to be returned./replaced. The second one, with low charge, I was able to get to charge eventually, by north swapping and re-arranging cables, after I had charged my original two B300s. However, I guess something with the AC-300’s logic, it still will not charge a “third” battery. Nowhere do I see a note that a person can’t use three batteries, although on a video they say to evenly distribute the batteries.

Maybe with an even number it “works”. Right now, there is no solution that it’s acceptable to me in terms of convenience, so I will return if it isn’t solved. The AC-300 “sees” all three batteries, but won’t charge (or discharge) one of them.

Since Bluetti customer service or tech support is non-existent…I can’t get any more information on troubleshooting. All firmware reports that there are no updates, by the way.

Still waiting for that RMA, but it’s been the weekend, so I didn’t expect much of anything. If it doesn’t happen promptly this week I may be giving up on the whole shebang-it is still less than 30 days for me and I’m not very satisfied.