B300 offline and blinking

Dear Bluetti,
I’m using 2x B300 batteries both with BMS firmware 1021.07 connected to an AC300 with DSP 4036.07.
Despite both B300 charge and discharge regularly, I notice the following behaviour with one of the two:

  • battery shows as OFFLINE on “Data → Battery Information” menu, that means “Battery On Line” always has a grey dot, NOT a green dot, even if “Battery State” change as usual from “Standby”, “Charge” and “Discharge”
  • battery power button sometimes blinks green 7 times
  • just sometimes, when I’m shutting down the AC300 by pressing its power button for 3 seconds, first the AC300 and both B300 power button lights are regularly going off, then after a few seconds the AC300 display alarm “BMS Communication Cable Error” with a beep, then after 1 second the system correctly power off

The B300 is already correctly SoC calibrated and all the cells VoC are in sync.
Additionally, since I have more AC series components:

  • I already tried using other B300 cables
  • I already tried to use another AC300 with the 2 batteries
  • I already tried to use that AC300 with other 2 batteries
  • I already mixed and swapped B300 and AC300 battery inputs

In fact the issue seems to be precisely related to that B300.
B300 was bought as new and it shipped with BMS firmware 1021.06, I updated it to 1021.07 just before the issue start to happen, so I confirm it was not showing the issue with firmware 1021.06, but I’m not sure how the new firmare could be related.
Is that an option for you to push me back to BMS firmware 1021.06?
Or else, please let me know how I can better diagnose the issue since battery itself is actually charging and discharging regularly.

@ndwr Kindly provide me with the SN of your AC300, then I can push you back to BMS firmware 1021.06 for you to test.

@BLUETTI_CARE Thank you, please push BMS firmware 1021.06 to: 2222000464183

Can you tell me which error is the B300 signalling when blinking 7 times?


If it flashes 7 times, the voltage of the single cell has too much difference.

Thank you. The firmware will be pushed in 24 hours. Please connect AC300 with that B300 and update the firmware, then do a full cycle of charge and discharge.

Thank you for the useful information.
For a few months, for cloudy weather reasons, the B300 was charged and discharged between 40-70% without any top balancing to 100%, so that got the cells slightly unbalanced and that’s why the B300 was blinking.
After a full charge/discharge and top balancing it a few times between 99 and 100% now the cells are all with equal voltages.
Despite this, even after a full discharge/charge calibration, and all the cells with the same voltage, the B300 still blinks 7 times sometimes and its “On Line State” results with a grey dot.
Can you confirm a grey dot means the B300 detected an internal error and so it’s being disconnected (not paralleled) to the AC300? Otherwise, what that exactly means?
I noticed the grey dot on the B300 with the issue always appear when there are more B300 connected together. In case of that only B300 connected alone, the dot is always green and battery works normally without any issue.
I received the pushed firmware which shows as 1021.20, but I couldn’t install it.
The situation is: AC300 connected only to the B300 with the issue on 56% SoC.
iPhone with the latest version App, connected to the AC300 via bluetooth with 3 bar signal. Firmware upgrade on BMS start without any problem, but as soon as the loading bar reach 50% I receive the error “Upgrade canceled.”.
Tried to restart both AC300 and phone, same issue.
Waiting for your advise.

Dear Bluetti,
I’m reporting again since I had the chance to check the B300 with the grey dot issue more throughly.
Differently from what I specified earlier, I confirm the issue is the same even with that B300 connected alone to an AC300.
I’ll list what I more specifically found:

  • the B300 itself disconnected from everything works without any problem, it power on and its DC outputs (USB and 12v outputs) works
  • the B300 can be charged by DC input via T500 without any problem at 530 W steadily
  • the B300 can be charged by PV input without any problem
  • the B300 only have an issue while charging by AC300 (tried 2 different AC300 with different battery cables)

Here is what happens by having an AC300 connected alone to that B300, same behaviour with 2 AC300 connected with 2 different battery cables:

  • B300 SoC is at 40%
  • B300 is with ALL the cells in sync at 3.33 VpC
  • AC300 start charging at low wattage (tried with AC and PV at about 400 watt)
  • after about 10 seconds B300 shutdown its DC input and so AC300 suddenly shutdown without any warning
  • B300 start blinking 7 times (?)
  • just before the B300 shutdown the AC300 all the B300 cells are at 3.42 VpC, all equal in sync without any difference

I’m thinking that the B300 blinking 7 times is not blinking 7 times.
I mean, B300 green LED button is steady green. When blinking it goes dark and than light.
The number of times it goes dark is 8.
Since all the B300 cells are perfectly of the same voltage when B300 is blinking, I’m supposing it’s reporting error 8 instead of error 7.
Error 7 means one cell has too much voltage difference, but that’s not the case here.
So just in case we’re having error 8 here, what does error 8 means?
I know I could ask for a replacement but since I think this problem is really simple, I would like to do anything to try to solve it first so I could leave some intel on the forum here for everybody in the future.

@ndwr Thank you very much for the detailed description. If it flashes 8 times, that means “Communication timeout with internal M1 board”. If this error occurs, the B300 will not be able to discharge normally when it is discharged alone. Our technicians believe this is not the fault. How you check the voltage of a single battery cell? Couold you take some pictures? If you connect AC300 with another B300, this problem will not occour, right?

Thank you for better looking into this.
Yes, that AC300 with other B300 works normally under every aspect.
Also that B300 with another AC300 has the same issue.
I was further looking into this after your confirmation about M1 board, I did a new setup with the same B300 alone connected with a different AC300 and a different battery cable (just to exclude them from the equation) and found the following:

  • B300 always discharge without any problem under any wattage from the AC300
  • B300 DC outputs always work without any problem
  • B300 can be charged by PV input and by DC barrel (using T500)

The issue happen ONLY when B300 is charging from AC300 with an AC current higher than 1 A.
If AC300 is set as 1 A, the B300 is charging from 0 to 100% without any issue.
If AC300 AC charging current is set as 2 or more A the following situation happen:

  • B300 start charging normally, DC bus voltage start to slowly rise
  • after about 10 seconds B300 shutdown its BMS DC output
  • when that happen AC300 suddenly shutdown without any warning (and that’s “normal” because it got suddenly no power from the battery)
  • at the same time, since M1 board power is supplied from BMS DC output, M1 board also shutdown
  • at that point, since BMS board remain powered up alone, it start to report a timeout with M1 board

So, it looks like the timeout with M1 board is not the problem here, but just a consequence of the BMS board suddenly cutting out DC power from DC bus.
And that only happen when from AC300 the charging current is set as more than 1 A.
So, what I’m thinking, but your technician can maybe confirm, is that the BMS board is cutting out DC output because:

  • it detect an out of specification charging current?
  • it detect an out of specification DC bus rising voltage while charging?

Is it possible the B300 unit lost some calibration values during last firmware update and so it detect a problem under a normal situation?

Please find 4 videos here that shows:

  • B300 discharging from AC300 at 1.5 kW (no issues here, can discharge like this from 100% to 0%)
  • B300 charging from AC300 with AC input of 1 A (no issues here, can charge like this from 0% to 100%)
  • B300 charging from AC300 with AC input of 2 A, B300 cutting off DC bus after a few seconds
  • B300 charging from AC300 with AC input of 2 A at voltages screen which shows no VoC issues


The multimeter is connected on the secondary battery plug to show DC bus it being steady on discharge and increasing as normal while charging.
Also, you can see that DC bus goes to 58/59 volt the moment B300 disconnects but I think this is perfectly normal since the moment it being disconnected AC300 is providing positive current so a sudden disconnect bring also a momentary peak on the bus charger side.
The yellow warning on AC300 is “DC bus voltage high” but I also think this is normal for the same reason and it looks like a consequence of the B300 DC bus being suddenly cut off.
My limited knowledge suggest me there is something not right, firmware side or calibration side, on the BMS board.

@ndwr Our technical engineer reported that the battery was overcharged and reported 004. Please check whether the BMS firmware is the latest and do a full cycle of charge and discharge.

Your multimeter measures the parallel port, not the DC output port, so it has nothing to do with the DC output; and the voltage measured in this way is not the DC bus voltage, but the battery pack voltage. However, after an overcharge error is reported later, the parallel port will stop supplying power to the AC300, so the voltage will slowly drop to 0.

Yes, with DC bus and voltage I indeed mean the battery pack bus and voltage, not the high voltage DC bus of the secondary of the inverter/charger, now I understand you call it parallel port so I will pay better attention to the terms so we can understand each other better.
That was on the multimeter to show your technician the battery voltage during the discharge/charge operation.
How did you find battery got overcharged if all of the cell voltages are within limits? (as shown on video)
On the AC300 history the alarm is 015 and not 004, which is “DC input voltage high”, but again that is thrown after the B300 cut the power to AC300 and not before, and since AC300 was charging it’s normal the DC input will have a peak (shown as 58 V on the multimeter) if battery is suddenly cut out. That is happening after the main issue, as a consequence, is not the main issue here.
Main issue is that B300 disconnect itself while the charging current is over a certain level, I’m sorry if I’m insisting on this, but that is the first event I’m detecting.
Would you like me to take a video of the BMS and M1 board LEDs while the issue is happening?
Also, would you like me to connect to the RS485 port of the B300 to better debug the issue? If you will provide instruction I will follow them.
In the meanwhile I will discharge to 0% and charge the B300 to 100% again. Since it’s only charging at 1 A AC (that’s about 5/6 A DC) it will require a while.
If I’m being too technical for what this forum is made for, which I understand, please let me know and I will stop reporting and proceeding to ask for a replacement.
Thank you for your time so far. :)

While trying another time to charge the B300 with an AC current of more than 1 ampere (from AC300) I noticed now the B300 is blinking 16 times as soon as the disconnection happen, and only after it’s blinking 8 times.
What error 16 means for the B300?


Our engineers noticed that in the video, the machine reported an error when it was almost fully charged. We speculated that it is because high-current charging is performed when it is almost fully charged, which can easily lead to overcharging and high voltage. In fact, we do not recommend rolling back the BMS firmware, the new BMS firmware is optimized for high battery voltage. We have re-pushed the new firmware to you, you can have a try.

Flashing 16 times means over-temperature.

Thank you for the explanation, I understand, however the same issue is happening at any battery %, also at low SoC.
Yesterday I discharged the B300 from the AC300 at about 3 kWh from 100% to 0%, without any problem, all the cells got to 2.8 V, then I tried to recharge it via AC300 at 2 A of AC current and got the same disconnection error after a few seconds. After that I set 1 A of AC current and it started charging normally, now is at 100% again.
So the issue is clear and repeatable.
Can you please send me a list of B300 blinking errors? So I will not ask you every time.
The over-temperature flashing is very interesting, I’m wondering if the whole issue is just related to an NTC temperature probe. Can your technician confirm that if a temperature sensor is bad, the B300 can only be charged at very low current?
About the firmware I’ve never rolled back because like I wrote some messages ago the App always said “Upgrade Canceled.” after reaching 50% of progress, so I’ve always been using the latest 1021.07.

@ndwr Sorry for my late reply. A bad NTC temperature probe does cause the B300 to flicker, if it’s bad, it won’t charge at a small current, but just disallow charging and discharging, if the NTC is bad, the machine will keep insisting that the machine is under-temperature, keep mis-detecting that it’s -20° and can’t be recovered from how to warm it up or how to leave it alone, if the machine can be restored to normal, it’s not the problem of NTC wire.

Dear Bluetti, thank you for the reply and happy Spring Festival. 新年快乐
Everything clear about the temperature probe, I’ll do some more tests and will report back.