AC50S does not fully charge with SP120

I charged my AC50S with the AC adapter to 100% first. Ran the unit down to 20% battery capacity and wanted to see how long it would take to charge the unit with the SP120 panel. 14 hours later (two days with clear skies, 88W average input) the battery was only at 40%. Tried charging it with the AC adapter over night and unit is still at 40%. I have now run the unit until the battery was shown at 0% and am trying to charge it with the AC adapter. This is my replacement unit from MaxOak. The 1st unit arrived with an 80% charge and I tried charging it with the SP120 first and the unit never got past 80%. Wouldn’t get to 100% with the AC adapter. Could the SP120 be causing some issue that prevents these units from fully charging? I have contacted MaxOak and am waiting for a response.

Two units and neither will charge (unusual situation to begin with) with either the AC adapter or solar panel is highly unusual. You state that the AC50S fully charged and only experienced the issue after connecting the solar panel? My first instinct is that there is something incorrect about the method of charging / connection? etc. Incorrect polarity coming into the AC200 from the solar panel? Are any adapters or extension cables being used that may have reversed polarity?

The common items that are present with both AC50S units are the Solar Panel (plus any connectors or extensions if present) and the operator. I would think logically that the answer most likely is within those two areas.

I figured out the issue and while it was an operator (me) error, it is unusual. I had seen on a YouTube video that you could charge the unit with the power off (like you do with a laptop). When I got the replacement unit, it was at 80% and I charged it over the AC with the unit off and I got to 100%. When I was charging this unit I also had it off with the solar and AC inputs. I went from 20 to 40% and the unit stopped charging. After searching through various YouTube videos and seeing that people left the unit on, I tried it that way. Plugged in the SP120, unit came on and after an hour I was at 60%. Couple hours later and I am now at 80%.

Good to hear. Turn the unit on and it works👍