AC50s DC draws without load

My ac50s is showing a DC load without anything plugged in and the output seems to be disabled as well.
The dc load was fluctuate up to 150w without anything plugged in

Any ideas?

@Bige311 hmm yea that’s a strange one! You aren’t able to turn off that dc button either?? I would try running a load on the AC side to completely discharge the unit. Then try charging it back up to kind of “reset” the unit. Definitely report back here your findings cause I’m interested as well but If that doesn’t work, I would then reach out to with an email for their suggestions.

Have you tried holding the main power button down for 7 seconds, pause for three seconds after the units turns off completely and then powering on again?

@Scott-Benson @m.briney

I tried the 7 second trick . The dc side is dead and now it won’t charge off solar?

How about charging via the ac charging brick or car charging. Are you also sure it is mot already fully charged?

Guys I returned this unit thanks for the help.