AC500 + 3 B300S 054 error - advice for new user

HI, purchased AC500 and one B300s in FEB of 23 used all summer in our off grid RV worked great using a mix of solar and a genny, bought 2 more B300s during black friday - we brought the units back home for the winter - have all 3 hooked up - charged to 100% plugged in my fridge to see how long i would get at 3 days it was at 49% in the morning went to work came home unit was off batts were drained . i read a couple articles about calibration …so charged to 100% plugged fridge back in and waiting to see…i have several question while waiting.

  1. how do i know if all of the firmware is up to date??
  2. i saw a article about running the batts in parallel? what is the best way to hook up 3 batts
  3. if it worked fine all summer with one batt why an issue now

i will be honest i want to LOVE my bluetti but its tough when you pay this kind of $$$$ it should work better

really appreciate ANY help


1 Like

@jsrore 1. When you log in to your account, bind your machine, and connect via Bluetooth, you can check the firmware version. When there is no new version prompt, it means that the official firmware version is already the latest.
2. I suggest you connect two battery packs to one expansion port and one battery pack to the other expansion port.

Great thanks for the good information
i will check via bluetooth, good to know and once the AC500 has gone thru this last test i will reconfigure the batts.
right now i have all 3 hooked up to one expansion port

thanks for the information

@jsrore I am glad to help you. For further problems, feel free to let me know.

@ Bluetti_care HI
i have gone through my last test today batts drained down to around 41%, SOC for batts are as follows #1 35%, #2 21%, #3 69% about a hour later i checked a hour later and it was down to 9%, batts 1 and 2 were at 0% #3 23% …i watched it for 3 minutes and in that time batt #3 dropped to 0 and unit shut down.

i have taken batts #2 and#3 and plugged them into the open expansion port, Im now charging the unit back up
i will run the test again with our fridge plugged in

any new help would be appreciated…

@jsrore When you do calibration, please connect one B300 with AC300 only, then do it one by one. When you do the full cycle of charge and discharge, please ignore the SOC. Please completely drain the battery until it automatically shuts down, and then charge it with AC until it is fully charged and automatically shuts down.

thank you , i will start working on this procedure.

i assume once i complete this procedure i should connect all 3 back up to the AC500 and run my test again?

ok so i have a new issue i went to turn on the AC500 to try the procedure you suggested
the head unit AC500 will not light up and the screen will not turn on, it turns on the batteries and will turn off the batteries, i tried one batt at a time and then all 3 and still same issue, i also plugged it into grid power with the same results.


OK so i just spent the last hour testing ALL the cables and batts and got it to power up it seems that my cables are a tad finicky, i got all the batts working on both ports of the AC500 some of the connection on the batts our very tough to push in , and that i need to get them just right to “lock” the cable as i just learned today that if its not locked… it wont turn on…

onward and upward…on to my testing…

1 Like

@jsrore Yes. Make sure the cables for the connection are locked.

i have completed the calibration of the 3 batts, discharged each batt by it self and then re charge the same way , i then connected all three back up to the AC500 , i connected 2 batts together and then into one expansion port and the other batt to the other expansion port.
i just finished the discharge using a space heater
i had very good success, AC500 went down all the way to 0% and then shut down, SOC of batts seemed much more evenly spaced

thank you for the advice
its good to have a running unit, learned a lot in the last week

@jsrore Thanks for your update. I’m glad to help you.

Cannot power on ac300. Is there another way to check firmware

Have you checked your battery connections to make sure that they are connected firmly and that they are locked in place? Mine would not work unless they were locked in place

@JohnM68 Yes. As @jsrore mentioned above, first of all, make sure the battery connections are locked in place.