AC300 won't charge at set amps

Hi, my AC300 charges only at about 530-560W whatever I do. This is about 2.4A. The unit goes down to 440-460W and to 220-230W if I set the max grid input power at 2A or 1A, but never reaches the charging current I set if it’s over 2. Tried resetting it, shutting down for some period of time and turning on again. It operates under room temperature of about +23C, hasn’t been loaded, so the battery should not be overheated.

I read several similar threads here, still don’t get how to deal with this. Thank you

Update: It also won’t charge to 100% although I have it in Standard UPS. It keeps hovering in between 89-90% just powering my fridge and drawing from the grid roughly the same current. Is it how the device is supposed to behave? Any way to overcome this?

I assume you’ve already set “Silent Mode” to off ?

Eco Off it is. It’s powering my fridge constantly anyways

@Oleksiy Is it AC charging? Would this also happen if it was DC charging? May I have the SN and the firmware version of your AC300?

It’s AC charging, I don’t have a DC charger to try.

The SN 2225000739997
DSP version 4036.07
ARM version 4037.05
HMI version 6035.05

To update, the situation has deteriorated significantly.

Now any attempt to connect the unit to the grid with Max grid input power set above 1A triggers a click in the battery with intermittent flashing of the on/off button, and subsequent shutdown of the AC300 unit. The battery continues to flash until I turn it off by long pressing on/off on the AC300.

Sometimes the system throws an alarm related to high voltage, which disappears in half a second. Once I also caught a 008. OCP (Over Current Protection) Hardware.

I understand the battery has gone into a protection mode and shuts itself down to protect itself. First it limited the charging power at 530-560W, now even 2A (440W) triggers a shutdown.

Is there a way to deal with this? A hard reset? The one done via the screen performs nothing. I suspect, this is not a hard reset at all, just bringing screen settings to some default state.


@Oleksiy I will push the firmware to you in 24 hours and you can update the firmware to test.

Thank you very much, look forward to it

@Oleksiy Please check the new firmware. Thank you.

@BLUETTI_CARE Hi, thank you for pushing the new FW to the unit, I have
DSP version 4036.30
ARM version 4037.07
HMI version 6035.05

The unit has been acting almost normally since the update. It keeps operating if I connect it to the grid with Max input power set over 1A, it also managed to charge to 100% overnight.

It still limits charging power to 530-560W though regardless of the Max input power amps setting - I tried, 3A, 5A and 7A.

I also found Advanced Settings in the Settings menu of the app. It provides for Grid Self-adaptation option and ability to set Max Charging Current, which is very convenient. I don’t recall I had this menu item before. I turned Grid Self-adaption on in case this may help with charging.

@Oleksiy Please do a full cycle of charge and discharge to test. Also, please provide me with the BMS version of your batteries.

1 Like

I’m unable to full cycle the battery reliably now, may end up with no fridge during summer. Power outages in Kyiv are getting mere and more severe.
The pack’s BMS version is 1021.07.

@Oleksiy I will push a new BMS firmware to your AC300 in 24 hours, please update the firmware to test.

1 Like

@BLUETTI_CARE , I have updated the BMS firmware to v1021.10, thank you. Unfortunately, this hasn’t helped either. I also have had new developments taking place recently:

  • My AC300 rolled back to switching off whenever the AC charging current exceeded 1A.
  • It also fails to charge the battery over 90% - just sits at this SOC in Standard UPS mode.
  • In order to charge the battery reliably in case power outages extend going forward, I purchased a T500 charger. Strangely enough, the AC300 won’t tolerate it either. Although I charge the B300, and this is DC charging. So once the T500 starts charging, the AC300 switches off, and then the B300 flashes its green button and stops charging too.
  • The most weird thing taking place - if operating in Standard UPS mode connected to the grid while AC powering my fridge, the AC300 started tripping a circuit breaker on the voltage stabilizer installed on this phase. How it manages to accomplish this I don’t know. But it happened three times, shortly after I connected the AC300 to the grid, albeit with max input charge power set at 1A (220-230W).

So my current operating mode is quite limited. I power the fridge and some other stuff (WiFi router) while neither AC300 or B300 are connected to the grid for charging. And I’m able to charge the battery only via T500 and only when I disconnect the battery from the AC300.

My understanding, there is something wrong with the AC300, it needs to be repaired. I’m considering my options now.

@Oleksiy I’m sorry to hear that. If the firmware update can’t solve the problem, please contact the after-sale support for repair.

1 Like