AC300 Will Not Turn On and Will Not Charge

Well, it appears I have joined the club.
My AC300 safely installed in my Ambo conversion will no longer come on (the light to the B300 comes on and blinks). I’ve tried house AC power and solar. Nothing. Notta. I used it approximately one month while traveling and aside from it losing seemingly a lot of power while off and nothing plugged it, it was awesome. Saturday it was fine and running my DC freezer for a while. Sunday I went to plug it in to house power to charge up for a short trip early in the week instead of solar charging because I am parked under a carport for a few days. It would not come on or charge. It had been at 70% Saturday night. Supposed to leave on another work trip in a matter of days and I have no idea what to do. I have kindly written (emailed) support and have received no response. I am devastated. Bragged about this setup and company all over the country for 3 weeks. Now I have no clue how I’m going to travel and work.
Anyone, please help.
Thank you.

Any chance the battery cable or cables aren’t locked in? I know on my AC500 if any of the sliding latches aren’t fully locked nothing will work.

1 Like

Thank you, I should have mentioned that, yes, I have checked and rechecked to be sure the cables are plugged in tightly, clean connections, sliding connections locked, etc. I checked everything again today and dragged out the 2 giant Bluetti 350 watt portable panels and tried charging with them, too.

@llewella , By your description: AC300 can not be turned on nor charged, and the lock has been checked. We have consulted the technical engineering for you, your machine needs to be returned for repairing.
May I know your email address and order number please? We can let the support department prioritize your email based on this information.

Thank you so much. I received a response and a new unit is being prepared to ship to me. I will find help to pack this unit for return. Thank you so very much for handling this.

1 Like

Hi Bluetti Team

unfortunately I have just the very same issue here - all wired correctly - but - after just 2 days of operation of my brand new Buletti AC300 with 2XB300 and 4Xsolar panel => AC300 is “dead” :frowning:

Can you pease provide some support for me as well?

Where to get in touch best? As my Support E-Mail also does not receive any answers (just resent it recently - but sent a first inquiry some days ago - invoice etc. can of cause be provided).

@hubi9402 , We felt deeply sorry for inconvenience caused. Could you please share us your order number and sending email via pravite message? (Click on my avatar and there is a Message button)
We will check with support and have them prioritize your email. Thanks!

Dear Adin

many thanks for answering. Unfortunately I cannot find the “Message” button?

Any idea why it is missing out?


Pravite message has been sent, please kindly check, thanks!

Many THX for your support here!

Hello from northern Germany.

I am actually facing the very same problem on a quite new system (purchased mid of October 2022).

Please send me a contact which can deal with the problem.

Many thanks in advance


Hi Getleman,

Update from my side - for my surprise after like 2 days and re-wiring everything and some time waiting it magically worked again…

I guess it is some kind of “over the internet update” that might take place - also no one really tells you / confirs. So just in case I would advise to kepp AC300 wired with B300 attached to it - maybe change connections - and wait when powering on…

Of casue @Bluetti Team => Would be kind of nice & “must have” to improve User Experience by letting us know in case an update takes place and show a progress or something…

Would have no other ideas why after some 2 days for my surprise the system went back powering on and booting just fine… (and continues to work as of today - crossing my fingers)


JR from also northern Germany

Hi hubi9402.

Many thanks for your comments.

I have tried to restart the AC300 several times already. Also I have un-pluged the connecting cable and re-installed it afterwards. No difference yet. The only thing I notice is a high pitch sound like a mosquito. But the display remains off…

Besides, did you receive any feedback from BLUETTI localy here in Germany? I have tried all offered channels to contact BLUETTI in Bremen but all lines are dead.


Hi together!
It seems to me there could be the same strange behaviour as with my little EB3A!?
Obviously in case of trouble it always helps to charge the Power Station via PV AND grid for a longer time!?
Perhaps this could help you too!?


Hi @hubi9402 , If you have provided the machine SN code with support, it should be our technical engineers updating the firmware for you in the background.

Hi @Gentleman , Have you ever contacted the support department

Hi Gentleman,

yes I did - though it took some time and support here was even quicker but by E-Mail (only E-Mail)… :slight_smile:


@BLUETTI THX for the hint - though no: I did not… So I assume that it might have been a general update? Anyway. Good that it is back working… :slight_smile:

Yes I did. But the adress has a malfunction. My message didn’t go through!

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of
its recipients. This is a permanent error.

The following address failed:
    SMTP error from remote server for TEXT command, host: ( reason: 554 Reject by content spam