AC300 + B300 loses charge quickly, only recharges ~600Wh


I purchased my AC300 + B300 directly from Bluetti on Feb 26. Arrived on Feb 29 (very fast), very well packaged, looks fantastic.

I have a constant issue which I’ve had since new - once the SOC falls to somewhere between 65% and 80% it counts down very quickly to 0%, gives the 054 D-BAT Drained alarm and shuts off AC and DC output. When I then try a mains recharge, it seems to charge normally for a short while (about 600W for the first 1%, then up to 2400W, SOC increases by about 1% each minute), but then at ~10% suddenly jumps to 100%, then 99%, then charges at 600W for a while until it says 100% and stops. In total it will only accept between 600Wh and 900Wh of energy which aligns with the input wattage and time it has charged, and I’ve confirmed it using my PowerPal mains monitor. I have searched the web for similar issues. Thinking it was a calibration issue, I have tried to drain the battery several times using a constant power source (heater on both 1000W and 2000W setting) and then full mains recharge, but cannot get much more than 600Wh into it from 0% to 100%. I have tried restricting the mains input to 3A but get the same result. I have tried switching the cable between the two BAT01 and BAT02 sockets on the battery and the AC300 with no impact. I regularly check for updates using the app - all 3 AC300 and B300 firmware say up to date.

One other minor issue - after a full recharge by mains to 100%, DC and AC (low power) output works fine, but as soon as I turn on something which draws more AC power (e.g. kettle 2000W, toaster 750W) the AC and DC outputs are turned off and I get the 016 DC Input Voltage Low alarm. I have found that if I turn on mains charging, then start the kettle, then turn off mains charging after the kettle has started then I don’t have this problem - can turn appliances on and off during the battery discharge - until the next full mains charge.

In mid March I added 3 x 300W Jinko solar panels. PV input works fine, I have achieved over 700W in direct sunlight.

I have now used this unit daily for 2 months and the problems have not changed. I am hoping the problem is just a software update given the unit seems to function correctly, other than it is like having a 600Wh battery and a battery indicator that does not work well.

I cannot find any other post in the forum that aligns with the issue I have. Is this a problem that you are aware of, presumably in very low numbers? Is there any other fixes I can try to resolve the issue?


1 Like

@srmanderson May I have the SN and the firmware version of AC300? Is the BMS version of the B300 latest?

Thank you,

SN 2225000062011 (Australia)

IoT v9014.12
ARM v4037.05
DSP v4036.07
BMS v1021.07 (showing as up to date)

Kind regards,

@srmanderson Please update the firmware to DSP403610, BMS102108 to test.

Thank you @BLUETTI_CARE ,

I updated the two firmwares as requested and have run the battery for 2 days, solar charging during the day and recharging to 100% by mains each night.

Unfortunately the two updates appear to have had no impact. The SOC still drops quickly to 0% once it gets down to around 80% SOC. When recharging, it still jumps to 99% within the first 10 minutes of charging, then charges for about 1 hour at ~600W until it says 100% and stops charging.

Is there anything else I can try?


@srmanderson After the firmware update, did you drain the battery and fully charge it without interuption?

When I did the upgrade, the battery SOC=80%, after the upgrade it was still 80%.

I did then drain the battery which didn’t take long as after using a couple of % it quickly went to 0%. I fully recharged it using mains, but again it jumped to 99% soon after I started charging (after reaching about 5%) and then charged for about 1 hour at ~600W, then it said 100% and stopped charging. I then used it yesterday, once it got below 80% it counted down very quickly to 0%, I recharged last night to 100%, again it only accepted around 700Wh, then today once it got near 80% it went down to 0%. On the display the SOC actually counts down, about 1% or 2% every second until it reaches 0%, then it switches off. During recharge I had AC and DC outputs switched off.

I have just started a recharge by mains. No load and no other input. I turned on the mains power at 9:01pm. At 9:10pm it was at 4% or 5% SOC, charging at 2400W (10A), then I heard it click and the SOC jumped to 100%, then after a few seconds to 99%. It is now charging at about 630W. It will most likely do this for about 1 hour, showing 99% SOC, before it hits 100% and stops. I will provide another update when it stops charging.

The SOC hit 100% at 10:05pm and has stopped drawing charge. So just under 1 hour at ~600W and a few minutes at the start at 2,400W. Mains is still switched on but drawing no power.

When you are discharge the unit start at the 100%, the put on a steady load (I’ve used a 1,500 watt heater) and leave it that way until the unit turns the AC output off (not just until it shows 0%). Then charge it at a constant rate from the grid until the charging actually stops. In this way the BMS can learn the true 0% and 100% values. :+1:

1 Like

Thank you @hnymann , but when the SOC reaches 0% the machine beeps 3 times, gives the 054 D-BAT Drained alarm and the AC and DC outputs get turned off. I don’t switch them off.

I have watched Jeff Hagen’s very helpful video “Recalibrate the battery meter in Bluetti solar generators” and attempted a few times to replicate by using a heater with a constant 1000W and a constant 2000W (thinking this was my issue), but each time it gets below 80% (might be 75%, might be 78%) it starts rapidly counting down to 0% and turns off the outputs. I then do a full recharge using mains but same issue when draining the battery, so I can’t get to a true 0% to calibrate.

The error you’re getting when discharging is normal when the battery gets fully discharged, including that the outputs turn themselves off, so that’s ok and is indicating that you are fully at “0%” (not true 0, but that’s as much as the Bluetti’s BMS allows the batteries to be discharged).

When charging back up you let it charge until there is no further grid wattage incoming.

That is supposed to be all you need to do to recalibrate the BMS. So, if you are having further strange behavior with your unit after you have done that, you might need to contact Bluetti support.

hi @BLUETTI_CARE , checking if there’s anything else I can try?

Since the software updates I have done 3 full mains charges and constant discharge at 1000W and the on discharge the SOC went to 0 each time when it reached 73%, 81% and 78%. On recharge it charged to 4% and 6%, then jumped to 100%, then 99% where it charged for about an hour and then stopped accepting grid input, reading 100%.

1 Like

@srmanderson I’m sorry there is no further suitable firmware for you to test. Please contact the after-sale support for repair.

Thank you @BLUETTI_CARE I appreciate your assistance. I have now contacted after-sales support.