AC200P - Low Volt/Amp on solar charge.

Hello All:

I have (2) 100W Rich Solar panels in series to charge the AC200p. First time i hooked everything up, the input on the bluetti display was showing low amps (1.5 - 2.0). Volts were around 37-41. Input watts would vary between 60-90 on a 1 second interval. Internet told me wiring/connections or controller could be a culprit.

I got a multimeter and ran through each panel while on the ground. Each panel was around 21V/3.5A and when put in series 43.7V/3.49A when tested directly on the panels. Generally

I thought maybe something with my wiring inside the van so the pictures below show the system set back up on the van and the test was at end of my wiring before bluetti connection. The last picture is the bluetti screen. All three pictures taken within 45 seconds of each other. A video would show the bluetti input volts/amps jumping around each second…sometime 5-7 volts. Multimeter was relatively steady reading.

Not sure where to go from here…can’t seem to get the input watts on the bluetti display over 90 or 92 on multiple sunny days, no clouds/shadows. Maybe something with the bluetti I might be missing?
Thanks in advance.


Didnt see anything wrong here to be honest.

When each Panel has around 21V with 3.5A and in Series it got 43.7V with 3.49A its double the voltage which happend when you connect in series, the Amps are still the same. Seems to be normal.

43.7V x 3.49A = 152W

Thats what you reached without connect to the AC200P. Okay value for 2x 100 Watts Panel.

I would check if there is any update available from the Bluetti App maybe this is just a displaying issue.


@EK-MT Have you changed the solar charging cable of AC200P to test?

Thanks for the response. Yeah…I was pretty happy with the 150W in series. Panels were laying flat and it was mid-afternoon. Not bad at all.

I have never updated the software…got it back in February 2021 and have only been using shore power. I will see if there is anything available.
Much Appreciated.

Thanks for the quick response. No, I only had the one cable that came with the generator. I will try the multimeter on the end of the charging cable and see if that might be the issue.

I have never updated software…is there a chance that might an issue?
Thanks again.

@EK-MT Looking forward to your update. I’m sorry AC200P does not support APP, so you can’t update the software.


Oh, didnt know that. Sorry for the wrong information @EK-MT


Thanks for following up. Rained yesterday so i got out today to test the charging cable. Slightly overcast. Voltage and amp reading were pretty consistent at the end of the panel MC4 connector (46.8V/2.63A) and at the end of the charging cable 2-pin aviation connection (45.9V/2.54A). I can only post the one picture as a new user it says…this one is voltage at 2-pin aviation.

I think the wiring/connectors are good throughout.
Thanks for any help.

1 Like

@EK-MT Kindly check if you have turned on PV mode.

Yes. It is in PV mode.

@EK-MT You can’t still get the input watts over 90 or 92 under the PV mode? How about car charging?