AC200 not initializing

I received my third replacement AC200, each of the earlier ones stopped working when I put them to sleep rather than turn them off. Now I know the difference. So I put in the new one today and didn’t turn it on. I just plugged in the PV cable. A little later I noticed that the screen was on. 92% power. I tried to tap and go to settings, but the screen was frozen, couldn’t change to anything. I powered off and on several times. Same thing. The screen says it is initializing and looks normal, but it never lets me go to settings, or turn on the DC or AC. What is going on?

Is sleep just the screen going black (but the green LED on the power button lit up) ?

Vs off with a single press of the power button so the green light goes off ?

A long press vs short press seems to do the same thing for my AC200Max

When you plug in the PV cable and are attached to solar panels that are producing in the voltage range needed, the AC200 will power on automatically.

I would unplug the PV cable, power off the ac200 by pressing the power BUTTON in for at least five seconds. Then do a short press of the power button to turn back on and see what happens. If everything is normal, charge to 100% and then discharge to 0% followed by an immediate recharge. Do this a couple of times to make sure all is OK. If the touch screen is still not usuable not sure what to offer unless you are wearning gloves? sweaty fingers? Unit overheated by being in direct sun?

It sounds like you ran the previous two AC200 batteries down (by not turning off) to a point of no return where they could not initiate charging. (By the way, were you asked to return the two non functioning AC200s? They could probably be revived by dissassembly and directly charging the batteries until they got above the minimum charging voltage. Then…normal charging should work.

I have a problem with my B230 battery, if it discharges to zero the AC200max will not recharge it. I found out that plugging in the AC brick to the battery make it start charging. It works fine both times I did it.
On your problem, try charging the AC200 with AC brick first.

Thanks Scott. I will try that. I don’t know that the PV ever provided enough to charge, but it must have provided enough to at least wake it up.

Yes, my previous AC200s were requested to be returned. You were the one who isolated the problem for me, thanks

PastedGraphic-9.png

Scott, I have tried. I removed the PV cable, charged it to 100%. I have powered it off and on several times while waiting inbetween. But I cannot discharge it because I cannot use it…the screen does not allow me to turn on either the AC or DC It just doesn’t move.

PastedGraphic-9.png

If I were a guessing man, I would guess that your replacement unit was a “refurb” unit with intermittent screen issues. I don’t know what else to say other than to try for #4.

An update…I just kept trying, and after two days the screen started to respond and I was able to turn on the AC and DC and discharge, then recharge the AC200. However I am finding that the AC output seems to turn itself off even when the frig is on…that is a little disconcerting.
Karl

PastedGraphic-9.png

Turn off the eco mode

thanks that makes sense. Once the fridge gets cold, it stops drawing, the unit senses no draw and turns off the AC output?

PastedGraphic-9.png